aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-08-27 15:34:27 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-31 07:56:39 +0700
commitdeffa0562a5247b69ec5ed3d01eec8b05ac9ea9a (patch)
tree0b3f372dbc40afbc01d62833c9aa7dfbba65bc26
parentfa35f8fbe8cb750eaf8fc36f8dfa5858af69479f (diff)
desktop/screenkey: Updated for version 1.5, new maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/screenkey/README2
-rw-r--r--desktop/screenkey/screenkey.SlackBuild46
-rw-r--r--desktop/screenkey/screenkey.info10
3 files changed, 25 insertions, 33 deletions
diff --git a/desktop/screenkey/README b/desktop/screenkey/README
index ffa4a48cdc9f..17067d748e46 100644
--- a/desktop/screenkey/README
+++ b/desktop/screenkey/README
@@ -1,2 +1,4 @@
+screenkey (screencast tool)
+
Screenkey is a screencast tool to display key strokes on the screen as
they are typed.
diff --git a/desktop/screenkey/screenkey.SlackBuild b/desktop/screenkey/screenkey.SlackBuild
index d9ab5525334c..0f497a093280 100644
--- a/desktop/screenkey/screenkey.SlackBuild
+++ b/desktop/screenkey/screenkey.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for screenkey
# Copyright 2013-2021 Benjamin Trigona-Harany
+# Copyright 2024 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +23,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240827 bkw:
+# - new maintainer.
+# - update for v1.5.
+# - add NEWS.rst and COPYING.txt to the doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=screenkey
-VERSION=${VERSION:-1.4}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.5}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,19 +53,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+# 20240827 bkw: no flags or libdir; pure python. this would be
+# noarch except that python modules go in lib64 on x86_64.
set -e
@@ -73,22 +65,20 @@ rm -rf $PRGNAM-$PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
python3 setup.py install --root=$PKG
install -D -m 0644 data/$PRGNAM.desktop \
$PKG/usr/share/applications/$PRGNAM.desktop
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -rf $PKG/usr/share/doc
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a README.rst NEWS.rst COPYING.txt $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/desktop/screenkey/screenkey.info b/desktop/screenkey/screenkey.info
index 07abf09f25ee..6d55e6216232 100644
--- a/desktop/screenkey/screenkey.info
+++ b/desktop/screenkey/screenkey.info
@@ -1,10 +1,10 @@
PRGNAM="screenkey"
-VERSION="1.4"
+VERSION="1.5"
HOMEPAGE="https://www.thregr.org/~wavexx/software/screenkey/"
-DOWNLOAD="https://www.thregr.org/~wavexx/software/screenkey/releases/screenkey-1.4.tar.gz"
-MD5SUM="5c95d8a50782892b825d531c20cb2236"
+DOWNLOAD="https://www.thregr.org/~wavexx/software/screenkey/releases/screenkey-1.5.tar.gz"
+MD5SUM="8ea06d3ae55ea5d5544ab0396c79be4b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="FontAwesome setuptools-git python3-babel slop"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"