aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsh Wiren <ash@spooksoftware.com>2010-05-13 00:27:45 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-13 00:27:45 +0200
commitc694de2aa113051d2b10fb106d2d4ee7bda77e61 (patch)
tree3a02f3be3531791c84629f21088cc816adc198e0
parentf15dc716a0ce67c2eae564140863de042480677c (diff)
downloadslackbuilds-c694de2aa113051d2b10fb106d2d4ee7bda77e61.tar.xz
graphics/dia: Updated for version 0.97
-rw-r--r--graphics/dia/README3
-rw-r--r--graphics/dia/dia-0.97-fixup_fr_mandir.patch12
-rw-r--r--graphics/dia/dia.SlackBuild46
-rw-r--r--graphics/dia/dia.info14
-rw-r--r--graphics/dia/doinst.sh9
-rw-r--r--graphics/dia/slack-desc6
6 files changed, 62 insertions, 28 deletions
diff --git a/graphics/dia/README b/graphics/dia/README
index 8de572ef7ecd..c333d2364ba5 100644
--- a/graphics/dia/README
+++ b/graphics/dia/README
@@ -7,6 +7,3 @@ objects to help draw entity relationship diagrams, UML diagrams,
flowcharts, network diagrams, and many other diagrams. It is also
possible to add support for new shapes by writing simple XML files,
using a subset of SVG to draw the shape.
-
-note: Occasionally the mirror may be quite busy, this might lead to
-possible problems in downloading.
diff --git a/graphics/dia/dia-0.97-fixup_fr_mandir.patch b/graphics/dia/dia-0.97-fixup_fr_mandir.patch
new file mode 100644
index 000000000000..01cb8f32ef1f
--- /dev/null
+++ b/graphics/dia/dia-0.97-fixup_fr_mandir.patch
@@ -0,0 +1,12 @@
+diff -Nur dia-0.97.orig/doc/fr/Makefile.in dia-0.97/doc/fr/Makefile.in
+--- dia-0.97.orig/doc/fr/Makefile.in 2009-05-03 13:12:41.000000000 -0500
++++ dia-0.97/doc/fr/Makefile.in 2009-10-12 17:44:25.949545398 -0500
+@@ -298,7 +298,7 @@
+ libexecdir = @libexecdir@
+ localedir = @localedir@
+ localstatedir = @localstatedir@
+-mandir = $(datadir)/man/$(lang)
++mandir = @mandir@/$(lang)
+ mkdir_p = @mkdir_p@
+ oldincludedir = @oldincludedir@
+ pdfdir = @pdfdir@
diff --git a/graphics/dia/dia.SlackBuild b/graphics/dia/dia.SlackBuild
index e3bc6ff8980f..e5367f6fd8cd 100644
--- a/graphics/dia/dia.SlackBuild
+++ b/graphics/dia/dia.SlackBuild
@@ -2,12 +2,14 @@
# Slackware build script for dia
# Written by Matt Hayes (dominian@slackadelic.com
+# Updated for 64bit by Ash Wiren (ash@spooksoftware.com 19-08-2009
PRGNAM=dia
-VERSION=0.96.1
+VERSION=0.97
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -15,31 +17,46 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
-cd $PRGNAM-$VERSION || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# Fixup the fr mandir
+patch -p1 < $CWD/dia-0.97-fixup_fr_mandir.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
- || exit 1
-
-make || exit 1
-make install DESTDIR=$PKG || exit 1
+ --mandir=/usr/man \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
@@ -47,9 +64,10 @@ make install DESTDIR=$PKG || exit 1
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog KNOWN_BUGS MAINTAINERS NEWS README THANKS TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+# docdir already exists :-)
+cp -a \
+ AUTHORS COPYING ChangeLog KNOWN_BUGS MAINTAINERS NEWS README THANKS TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -57,4 +75,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/dia/dia.info b/graphics/dia/dia.info
index 8bf47073de64..c140a81c2dfe 100644
--- a/graphics/dia/dia.info
+++ b/graphics/dia/dia.info
@@ -1,8 +1,10 @@
PRGNAM="dia"
-VERSION="0.96.1"
+VERSION="0.97"
HOMEPAGE="http://www.gnome.org/projects/dia/"
-DOWNLOAD="ftp://ftp.gnome.org/pub/gnome/sources/dia/0.96/dia-0.96.1.tar.bz2"
-MD5SUM="7b81b22baa2df55efe4845865dddc7b6"
-MAINTAINER="Matt Hayes"
-EMAIL="dominian@slackadelic.com"
-APPROVED="Michiel"
+DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/dia/0.97/dia-0.97.tar.bz2"
+MD5SUM="3d11f9aaa5a4923f0a5533962c87bdfb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Ash Wiren"
+EMAIL="ash@spooksoftware.com"
+APPROVED="rworkman"
diff --git a/graphics/dia/doinst.sh b/graphics/dia/doinst.sh
index 3412314ed009..1f8ff67dedb2 100644
--- a/graphics/dia/doinst.sh
+++ b/graphics/dia/doinst.sh
@@ -1,5 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
-if [ -x usr/bin/update-desktop-database ]; then
- ./usr/bin/update-desktop-database ./usr/share/applications >/dev/null 2>&1
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
fi
diff --git a/graphics/dia/slack-desc b/graphics/dia/slack-desc
index 15031e36194d..46b31cb647cf 100644
--- a/graphics/dia/slack-desc
+++ b/graphics/dia/slack-desc
@@ -5,9 +5,9 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler------------------------------------------------------|
dia: Dia (diagram creation program)
-dia:
+dia:
dia: Dia is inspired by the commercial Windows program 'Visio', though
dia: more geared towards informal diagrams for casual use. It can be used
dia: to draw many different kinds of diagrams. It currently has special
@@ -15,5 +15,5 @@ dia: objects to help draw entity relationship diagrams, UML diagrams,
dia: flowcharts, network diagrams, and many other diagrams. It is also
dia: possible to add support for new shapes by writing simple XML files,
dia: using a subset of SVG to draw the shape.
-dia:
+dia:
dia: Homepage: http://www.gnome.org/projects/dia/