aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2022-05-21 07:48:08 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-28 09:11:31 +0700
commitc18c4678c7366cf2a0921a40c10a2c527a46dce7 (patch)
tree29a5423478249e82192d55e9a7d363db31eb1ef1
parent07eaf3e32bcdfc71bbffd558fdd310e5aabaa88f (diff)
python/python-oauthlib: Remove python3 test. Make python2 explicit.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-oauthlib/python-oauthlib.SlackBuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/python/python-oauthlib/python-oauthlib.SlackBuild b/python/python-oauthlib/python-oauthlib.SlackBuild
index 2299ac3e9acb..c9acb8e1bb97 100644
--- a/python/python-oauthlib/python-oauthlib.SlackBuild
+++ b/python/python-oauthlib/python-oauthlib.SlackBuild
@@ -80,12 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# python3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true