aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2023-11-02 16:57:09 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-04 16:41:34 +0700
commit83d366a5f2ed13181fa620fca4f1d9efc1c58871 (patch)
tree36d69c3bff1d98d7a95de525f79423392b71e699
parentae95b6f258a4ad2d1d7bf2a9088d80618150948a (diff)
downloadslackbuilds-83d366a5f2ed13181fa620fca4f1d9efc1c58871.tar.xz
graphics/pygifme: Removed (unmaintained).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--graphics/pygifme/README2
-rw-r--r--graphics/pygifme/pygifme.SlackBuild102
-rw-r--r--graphics/pygifme/pygifme.info10
-rw-r--r--graphics/pygifme/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/graphics/pygifme/README b/graphics/pygifme/README
deleted file mode 100644
index 78e2077d3f76..000000000000
--- a/graphics/pygifme/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Pygifme is a simple command line tool to generate animated GIFs.
-script gifme created by Zach Holman.
diff --git a/graphics/pygifme/pygifme.SlackBuild b/graphics/pygifme/pygifme.SlackBuild
deleted file mode 100644
index 731a4d652599..000000000000
--- a/graphics/pygifme/pygifme.SlackBuild
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pygifme
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220222 bkw: Modified by SlackBuilds.org, BUILD=2: fix build on 15.0.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pygifme
-VERSION=${VERSION:-0.1}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-# 20220227 bkw: uhhh...
-# AttributeError: module 'platform' has no attribute 'dist'
-# ...this is just a print(), it doesn't *do* anything.
-sed -i "/print.*'Distribution:'/d" setup.py
-
-python3 setup.py install --root=$PKG
-
-rm -rf $PKG/usr/share
-
-# 20220227 bkw: we don't need a shell script for this...
-rm -f $PKG/usr/bin/$PRGNAM
-ln -s $PRGNAM.py $PKG/usr/bin/$PRGNAM
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/pygifme/pygifme.info b/graphics/pygifme/pygifme.info
deleted file mode 100644
index b858dbcf016c..000000000000
--- a/graphics/pygifme/pygifme.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pygifme"
-VERSION="0.1"
-HOMEPAGE="https://github.com/shakaran/pygifme"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pygifme/pygifme-0.1.tar.gz"
-MD5SUM="44a086ea3d1d5a0ca880085db1df982d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="argcomplete"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/graphics/pygifme/slack-desc b/graphics/pygifme/slack-desc
deleted file mode 100644
index 5017fa77fc1f..000000000000
--- a/graphics/pygifme/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pygifme: pygifme (simple command line tool to generate GIFs)
-pygifme:
-pygifme: Pygifme is a simple command line tool to
-pygifme: generate animated GIFs. It is a python port from
-pygifme: the original ruby script gifme created by Zach Holman.
-pygifme:
-pygifme:
-pygifme:
-pygifme:
-pygifme: Homepage: https://github.com/shakaran/pygifme
-pygifme: