aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-08-30 15:06:16 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-31 07:56:40 +0700
commit6862b65540c2bc61723e9dd79dd8005102460c38 (patch)
treeb55f98d71309e0dbcecca5105ecd4bf689bf9a36
parent0e4a79858741b45c0d328c36f7ae849789abc698 (diff)
system/gpart: New maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/gpart/README2
-rw-r--r--system/gpart/docdir.diff11
-rw-r--r--system/gpart/docdir.diff.gzbin221 -> 0 bytes
-rw-r--r--system/gpart/gpart.SlackBuild65
-rw-r--r--system/gpart/lvm2-btrfs.diff14
-rw-r--r--system/gpart/lvm2-btrfs.diff.gzbin245 -> 0 bytes
6 files changed, 48 insertions, 44 deletions
diff --git a/system/gpart/README b/system/gpart/README
index 77bb753aca0c..ff4ed3f8eeb0 100644
--- a/system/gpart/README
+++ b/system/gpart/README
@@ -1,3 +1,5 @@
+gpart (Guess PC-type hard disk partitions)
+
Gpart is a small tool which tries to guess what partitions are on a
PC type, MBR-partitioned hard disk in case the primary partition table
was damaged.
diff --git a/system/gpart/docdir.diff b/system/gpart/docdir.diff
new file mode 100644
index 000000000000..d27c22f441d6
--- /dev/null
+++ b/system/gpart/docdir.diff
@@ -0,0 +1,11 @@
+diff --git a/Makefile.am b/Makefile.am
+index 51932b2..72b5914 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,5 @@
+ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = src man
+
+-docdir = $(datadir)/doc/@PACKAGE@
+ doc_DATA = Changes README.md
+ EXTRA_DIST = Changes README.md
diff --git a/system/gpart/docdir.diff.gz b/system/gpart/docdir.diff.gz
deleted file mode 100644
index 6dfbdd52dad6..000000000000
--- a/system/gpart/docdir.diff.gz
+++ /dev/null
Binary files differ
diff --git a/system/gpart/gpart.SlackBuild b/system/gpart/gpart.SlackBuild
index 1dddc0a2511b..c319a84ca314 100644
--- a/system/gpart/gpart.SlackBuild
+++ b/system/gpart/gpart.SlackBuild
@@ -2,31 +2,22 @@
# Slackware build script for gpart
-# Copyright 2015-2016 Hunter Sezen California, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Original author: Hunter Sezen.
+# Modified and now maintained by B. Watson <urchlay@slackware.uk>.
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20240830 bkw: BUILD=3.
+# - new maintainer.
+# - relicense as WTFPL.
+# - no INSTALL in doc dir.
+# - store patches non-gzipped.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gpart
VERSION=${VERSION:-0.3}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +29,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,16 +40,12 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -73,19 +57,16 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# Add LVM2 and btrfs to list of supported modules
# https://github.com/baruch/gpart/commit/610741608381635064c15030f35714dd113f76af
-zcat $CWD/lvm2-btrfs.diff.gz | patch -p1
+patch -p1 < $CWD/lvm2-btrfs.diff
# Respect configure --docdir option
# https://github.com/baruch/gpart/commit/5fa7b6f405ae651af06a50e85c80cc2a76116538
-zcat $CWD/docdir.diff.gz | patch -p1
+patch -p1 < $CWD/docdir.diff
# generate the configure file
sed '/configure/d' -i autogen.sh
@@ -100,17 +81,13 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man*/*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING Changes INSTALL LSM README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a COPYING LSM $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/gpart/lvm2-btrfs.diff b/system/gpart/lvm2-btrfs.diff
new file mode 100644
index 000000000000..9a7c48ee15ba
--- /dev/null
+++ b/system/gpart/lvm2-btrfs.diff
@@ -0,0 +1,14 @@
+diff --git a/README.md b/README.md
+index 7cd3e2d..330821b 100644
+--- a/README.md
++++ b/README.md
+@@ -41,7 +41,8 @@ See file *INSTALL*.
+ qnx4 | 0x4F | QNX 4.x
+ beos | 0xEB | BeOS fs
+ xfs | 0x83 | SGI XFS filesystem
+-
++ btrfs | 0x83 | BtrFS
++ LVM2 | 0x8E | LVM2
+
+
+ ## Guessing modules
diff --git a/system/gpart/lvm2-btrfs.diff.gz b/system/gpart/lvm2-btrfs.diff.gz
deleted file mode 100644
index d45dcae710d2..000000000000
--- a/system/gpart/lvm2-btrfs.diff.gz
+++ /dev/null
Binary files differ