aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVijay Marcel <vijaymrcel@outlook.com>2023-07-17 09:59:50 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-17 09:59:50 +0700
commit47799d3b32405b731f51c4ab720663655197e5ac (patch)
treeef7ee9ae023064844d341a0717d4fd056efd48c9
parent82beed919990c9d962a462cdab24b2a76d401a04 (diff)
python/python-fonttools: Updated for version 4.39.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-fonttools/README11
-rw-r--r--python/python-fonttools/python-fonttools.SlackBuild26
-rw-r--r--python/python-fonttools/python-fonttools.info12
3 files changed, 33 insertions, 16 deletions
diff --git a/python/python-fonttools/README b/python/python-fonttools/README
index 6b4b084746c7..54c96a23e4e3 100644
--- a/python/python-fonttools/README
+++ b/python/python-fonttools/README
@@ -1 +1,12 @@
python-fonttools - A library to manipulate font files from Python.
+
+Optional dependencies:
+
+lxml – faster backend for XML files reading/writing
+
+python3-matplotlib – for visualizing
+DesignSpaceDocument and resulting VariationModel
+
+python-reportlab – to drawing glyphs as PNG images
+
+python3-sympy – for symbolic font statistics analysis
diff --git a/python/python-fonttools/python-fonttools.SlackBuild b/python/python-fonttools/python-fonttools.SlackBuild
index 11101ffe1a5e..541dcfa76e1a 100644
--- a/python/python-fonttools/python-fonttools.SlackBuild
+++ b/python/python-fonttools/python-fonttools.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-fonttools
# Copyright 2017-2019,2022 Andrew Clemons, Wellington New Zealand
+# Copyright 2023 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-fonttools
SRCNAM=fonttools
-VERSION=${VERSION:-4.33.3}
+VERSION=${VERSION:-4.39.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,13 +50,13 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
+ SLKCFLAGS="-march=x86-64 -mtune=native -pipe -O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -77,22 +78,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr
-rm -rf $PKG/usr/share
+mv -v $PKG/usr/share/man $PKG/usr
+rm -rvf $PKG/usr/share
+
+cd Doc
+make singlehtml
+make man
+mv -v $TMP/$SRCNAM-$VERSION/Doc/build/man/fonttools.1 $PKG/usr/man/man1/
+cd ..
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CONTRIBUTING.md LICENSE.external README.rst CODE_OF_CONDUCT.md NEWS.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CONTRIBUTING.md LICENSE.external LICENSE README.rst CODE_OF_CONDUCT.md NEWS.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/python-fonttools/python-fonttools.info b/python/python-fonttools/python-fonttools.info
index 7cc5c6cfa145..5589bb8fc55a 100644
--- a/python/python-fonttools/python-fonttools.info
+++ b/python/python-fonttools/python-fonttools.info
@@ -1,10 +1,10 @@
PRGNAM="python-fonttools"
-VERSION="4.33.3"
+VERSION="4.39.4"
HOMEPAGE="https://github.com/fonttools/fonttools"
-DOWNLOAD="https://github.com/fonttools/fonttools/archive/4.33.3/fonttools-4.33.3.tar.gz"
-MD5SUM="378cddfc03ce99542b4bf39126d887ee"
+DOWNLOAD="https://github.com/fonttools/fonttools/archive/4.39.4/fonttools-4.39.4.tar.gz"
+MD5SUM="fbdb8b744ba6826c4ebf5c0753232257"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-unicodedata2"
-MAINTAINER="Andrew Clemons"
-EMAIL="andrew.clemons@gmail.com"
+REQUIRES="python-unicodedata2 Sphinx sphinx-rtd-theme munkres python3-scipy zopfli python3-fs python3-uharfbuzz freetype-py python3-ufolib2"
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymrcel@outlook.com"