aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-09 17:00:33 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-09 21:37:24 +0700
commit1aa1106c44f54ec7c1a2d0c9cb0347dff8f4037d (patch)
treef6061a5741b2d1af00c271fb34259617156f50b5
parentb73362077c2e2b9b9b70ff2c504e9025cc05d687 (diff)
python/pymongo: Switch to new PEP517 and add missing dep.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pymongo/pymongo.SlackBuild10
-rw-r--r--python/pymongo/pymongo.info2
2 files changed, 6 insertions, 6 deletions
diff --git a/python/pymongo/pymongo.SlackBuild b/python/pymongo/pymongo.SlackBuild
index 157f28ee3b61..f32c8c6bc8e2 100644
--- a/python/pymongo/pymongo.SlackBuild
+++ b/python/pymongo/pymongo.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pymongo
VERSION=${VERSION:-4.6.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,7 +77,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pymongo/pymongo.info b/python/pymongo/pymongo.info
index 713047e2fdcd..829f2a9273e2 100644
--- a/python/pymongo/pymongo.info
+++ b/python/pymongo/pymongo.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/1d/f0/b5fcf9aee64ac3650a3df3bd
MD5SUM="7c854a2d1e2ce333ed875edfdd034e9c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="dslackw@gmail.com"