aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Clemons <andrew.clemons@gmail.com>2022-02-09 22:06:11 +1300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-09 17:02:22 +0700
commit19632d14ed566d19f12db85723e14e57485b0226 (patch)
tree3b7fae2eff8e9ea1cb1758a6c9eff6d204cad3ae
parent295fb8c85c8734f04ae31b3b3555faede2982901 (diff)
downloadslackbuilds-19632d14ed566d19f12db85723e14e57485b0226.tar.xz
python/python2-blake2: Removed (unused, python2, ftbfs).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python2-blake2/README2
-rw-r--r--python/python2-blake2/python2-blake2.SlackBuild96
-rw-r--r--python/python2-blake2/python2-blake2.info10
-rw-r--r--python/python2-blake2/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/python2-blake2/README b/python/python2-blake2/README
deleted file mode 100644
index 75554bee0b34..000000000000
--- a/python/python2-blake2/README
+++ /dev/null
@@ -1,2 +0,0 @@
-blake2 hash function module for python written by Bae KwonHan.
-License: Public Domain
diff --git a/python/python2-blake2/python2-blake2.SlackBuild b/python/python2-blake2/python2-blake2.SlackBuild
deleted file mode 100644
index 3d3f17cee4f1..000000000000
--- a/python/python2-blake2/python2-blake2.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-blake2
-
-# Copyright 2013 Markus Reichelt, Stolberg (Rhld.), DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python2-blake2
-SRCNAM=blake2
-VERSION=${VERSION:-0.1.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-blake2/python2-blake2.info b/python/python2-blake2/python2-blake2.info
deleted file mode 100644
index 99ef08d06d83..000000000000
--- a/python/python2-blake2/python2-blake2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-blake2"
-VERSION="0.1.6"
-HOMEPAGE="https://pypi.python.org/pypi/blake2/"
-DOWNLOAD="https://pypi.python.org/packages/source/b/blake2/blake2-0.1.6.tar.gz"
-MD5SUM="bcdbebfa3ccf5ed46328face6c7f5fce"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/python2-blake2/slack-desc b/python/python2-blake2/slack-desc
deleted file mode 100644
index 8afba0d13aeb..000000000000
--- a/python/python2-blake2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-blake2: python2-blake2 (blake2 python module)
-python2-blake2:
-python2-blake2: This module handles the blake2 hash function.
-python2-blake2:
-python2-blake2: Homepage: https://pypi.python.org/pypi/blake2/
-python2-blake2:
-python2-blake2:
-python2-blake2:
-python2-blake2:
-python2-blake2:
-python2-blake2: