aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-07-05 22:18:10 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-07-06 12:16:39 +0700
commit052e533ab7451f7ba13c588146b623346366d1ca (patch)
tree58ede9f547a36591f804e21efcb883a6ae15ee00
parent3181352898ec8918fb4f59e8d492fbe74611609d (diff)
libraries/rapidjson: Fix build on current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/rapidjson/3b2441b8.patch22
-rw-r--r--libraries/rapidjson/rapidjson.SlackBuild5
2 files changed, 26 insertions, 1 deletions
diff --git a/libraries/rapidjson/3b2441b8.patch b/libraries/rapidjson/3b2441b8.patch
new file mode 100644
index 0000000000000..0799d22aa02d4
--- /dev/null
+++ b/libraries/rapidjson/3b2441b8.patch
@@ -0,0 +1,22 @@
+From 3b2441b87f99ab65f37b141a7b548ebadb607b96 Mon Sep 17 00:00:00 2001
+From: Janusz Chorko <janusz.chorko@apdu.pl>
+Date: Fri, 26 Aug 2016 21:17:38 +0200
+Subject: [PATCH] Removed non-compiling assignment operator. Fixed #718
+
+---
+ include/rapidjson/document.h | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/include/rapidjson/document.h b/include/rapidjson/document.h
+index e3e20dfbd..b0f1f70be 100644
+--- a/include/rapidjson/document.h
++++ b/include/rapidjson/document.h
+@@ -316,8 +316,6 @@ struct GenericStringRef {
+
+ GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
+
+- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
+-
+ //! implicit conversion to plain CharType pointer
+ operator const Ch *() const { return s; }
+
diff --git a/libraries/rapidjson/rapidjson.SlackBuild b/libraries/rapidjson/rapidjson.SlackBuild
index 029cf9421df1d..5f6f1c6aabb8f 100644
--- a/libraries/rapidjson/rapidjson.SlackBuild
+++ b/libraries/rapidjson/rapidjson.SlackBuild
@@ -31,7 +31,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rapidjson
VERSION=${VERSION:-1.1.0}
GTESTVER=${GTESTVER:-ba96d0b1161f540656efdaed035b3c062b60e006}
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-5}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,6 +87,9 @@ find -L . \
# Fix for gcc7+
find -name CMakeLists.txt -exec sed -i 's/ -Werror//g' {} +
+# Fix for current
+patch -p1 < $CWD/3b2441b8.patch
+
mkdir -p build
cd build
cmake \