aboutsummaryrefslogtreecommitdiff
path: root/ui/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2023-11-03 09:17:48 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2023-12-31 09:11:29 +0100
commitd0cda6f461fd33c5f9b063781c63c1ce5fd3fa3b (patch)
treec48bd2a0ab0da96761a6b75cdb66cb1ed36a5090 /ui/meson.build
parentcfc1a889e509ffeba6e44cca8ff626751bc4219e (diff)
configure, meson: rename targetos to host_os
This variable is about the host OS, not the target. It is used a lot more since the Meson conversion, but the original sin dates back to 2003. Time to fix it. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'ui/meson.build')
-rw-r--r--ui/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/ui/meson.build b/ui/meson.build
index a370494c4a..376e0d771b 100644
--- a/ui/meson.build
+++ b/ui/meson.build
@@ -25,7 +25,7 @@ endif
system_ss.add([spice_headers, files('spice-module.c')])
system_ss.add(when: spice_protocol, if_true: files('vdagent.c'))
-if targetos == 'linux'
+if host_os == 'linux'
system_ss.add(files('input-linux.c', 'udmabuf.c'))
endif
system_ss.add(when: cocoa, if_true: files('cocoa.m'))
@@ -75,7 +75,7 @@ endif
if dbus_display
dbus_ss = ss.source_set()
env = environment()
- env.set('TARGETOS', targetos)
+ env.set('HOST_OS', host_os)
xml = custom_target('dbus-display preprocess',
input: 'dbus-display1.xml',
output: 'dbus-display1.xml',
@@ -105,7 +105,7 @@ if dbus_display
endif
if gtk.found()
- if targetos == 'windows'
+ if host_os == 'windows'
system_ss.add(files('win32-kbd-hook.c'))
endif
@@ -121,7 +121,7 @@ if gtk.found()
endif
if sdl.found()
- if targetos == 'windows'
+ if host_os == 'windows'
system_ss.add(files('win32-kbd-hook.c'))
endif