aboutsummaryrefslogtreecommitdiff
path: root/target/sparc/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@linaro.org>2023-06-13 15:33:47 +0200
committerRichard Henderson <richard.henderson@linaro.org>2023-06-20 10:01:30 +0200
commitde6cd7599b518f0c832cc85980196ec02c129a86 (patch)
tree0b7d445fa70756ff121dd7cd23bfbae24ea0a98b /target/sparc/meson.build
parentc7b64948f8ae4142b65f644164d0678892fe223d (diff)
meson: Replace softmmu_ss -> system_ss
We use the user_ss[] array to hold the user emulation sources, and the softmmu_ss[] array to hold the system emulation ones. Hold the latter in the 'system_ss[]' array for parity with user emulation. Mechanical change doing: $ sed -i -e s/softmmu_ss/system_ss/g $(git grep -l softmmu_ss) Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20230613133347.82210-10-philmd@linaro.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'target/sparc/meson.build')
-rw-r--r--target/sparc/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/sparc/meson.build b/target/sparc/meson.build
index a801802ee2..d32e67b287 100644
--- a/target/sparc/meson.build
+++ b/target/sparc/meson.build
@@ -12,12 +12,12 @@ sparc_ss.add(files(
sparc_ss.add(when: 'TARGET_SPARC', if_true: files('int32_helper.c'))
sparc_ss.add(when: 'TARGET_SPARC64', if_true: files('int64_helper.c', 'vis_helper.c'))
-sparc_softmmu_ss = ss.source_set()
-sparc_softmmu_ss.add(files(
+sparc_system_ss = ss.source_set()
+sparc_system_ss.add(files(
'machine.c',
'mmu_helper.c',
'monitor.c',
))
target_arch += {'sparc': sparc_ss}
-target_softmmu_arch += {'sparc': sparc_softmmu_ss}
+target_softmmu_arch += {'sparc': sparc_system_ss}