aboutsummaryrefslogtreecommitdiff
path: root/target/sparc/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2023-10-01 14:56:04 -0700
committerRichard Henderson <richard.henderson@linaro.org>2023-10-25 01:01:12 -0700
commit878cc6773a69f9018357ff673f258acef58422b3 (patch)
tree48f0c10ea040ced77d5c63c44ddfa8eaa0784326 /target/sparc/meson.build
parent554abe47c7b4b68c716edb68b8843f64490d7e55 (diff)
target/sparc: Add decodetree infrastructure
Tested-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk> Acked-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'target/sparc/meson.build')
-rw-r--r--target/sparc/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/sparc/meson.build b/target/sparc/meson.build
index 48025cce76..c316773db6 100644
--- a/target/sparc/meson.build
+++ b/target/sparc/meson.build
@@ -1,4 +1,7 @@
+gen = decodetree.process('insns.decode')
+
sparc_ss = ss.source_set()
+sparc_ss.add(gen)
sparc_ss.add(files(
'cc_helper.c',
'cpu.c',