aboutsummaryrefslogtreecommitdiff
path: root/target/loongarch/meson.build
diff options
context:
space:
mode:
authorTianrui Zhao <zhaotianrui@loongson.cn>2024-01-05 15:58:04 +0800
committerSong Gao <gaosong@loongson.cn>2024-01-11 19:22:47 +0800
commit714b03c12599a8ce19d51cc1cd40631796c9e4f6 (patch)
tree8f8c45bae375c18b570f1506b8d713079ca8abb0 /target/loongarch/meson.build
parent8dcbad5128b5dc855f687d562ac223b06f2259a4 (diff)
target/loongarch: Add loongarch kvm into meson build
Add kvm.c into meson.build to compile it when kvm is configed. Meanwhile in meson.build, we set the kvm_targets to loongarch64-softmmu when the cpu is loongarch. And fix the compiling error when config is enable-kvm,disable-tcg. Signed-off-by: Tianrui Zhao <zhaotianrui@loongson.cn> Signed-off-by: xianglai li <lixianglai@loongson.cn> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Reviewed-by: Song Gao <gaosong@loongson.cn> Message-Id: <20240105075804.1228596-10-zhaotianrui@loongson.cn> Signed-off-by: Song Gao <gaosong@loongson.cn>
Diffstat (limited to 'target/loongarch/meson.build')
-rw-r--r--target/loongarch/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/loongarch/meson.build b/target/loongarch/meson.build
index e84e4c51f4..db310f6022 100644
--- a/target/loongarch/meson.build
+++ b/target/loongarch/meson.build
@@ -18,3 +18,4 @@ subdir('tcg')
target_arch += {'loongarch': loongarch_ss}
target_system_arch += {'loongarch': loongarch_system_ss}
+subdir('kvm')