aboutsummaryrefslogtreecommitdiff
path: root/softmmu/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-10-06 09:05:29 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-10-12 11:50:22 -0400
commitd9f24bf57241453e078dba28d16fe3a430f06da1 (patch)
tree7fde45ae523f07d26f76c8c1711628fd6ac3dae2 /softmmu/meson.build
parent800d4deda04be016a95fbbf397c830a2d14ff9f6 (diff)
exec: split out non-softmmu-specific parts
Over the years, most parts of exec.c that were not specific to softmmu have been moved to accel/tcg; what's left is mostly the low-level part of the memory API, which includes RAMBlock and AddressSpaceDispatch. However exec.c also hosts 4-500 lines of code for the target specific parts of the CPU QOM object, plus a few functions for user-mode emulation that do not have a better place (they are not TCG-specific so accel/tcg/user-exec.c is not a good place either). Move these parts to a new file, so that exec.c can be moved to softmmu/physmem.c. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'softmmu/meson.build')
-rw-r--r--softmmu/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/softmmu/meson.build b/softmmu/meson.build
index 862ab24878..8f7210b4f0 100644
--- a/softmmu/meson.build
+++ b/softmmu/meson.build
@@ -3,6 +3,7 @@ specific_ss.add(when: 'CONFIG_SOFTMMU', if_true: [files(
'balloon.c',
'cpus.c',
'cpu-throttle.c',
+ 'physmem.c',
'ioport.c',
'memory.c',
'memory_mapping.c',
@@ -19,7 +20,7 @@ softmmu_ss.add(files(
'bootdevice.c',
'dma-helpers.c',
'qdev-monitor.c',
-), sdl)
+), sdl, libpmem, libdaxctl)
softmmu_ss.add(when: 'CONFIG_TPM', if_true: files('tpm.c'))
softmmu_ss.add(when: 'CONFIG_SECCOMP', if_true: [files('qemu-seccomp.c'), seccomp])