aboutsummaryrefslogtreecommitdiff
path: root/rust/qemu-api/Cargo.toml
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2024-10-24 11:33:07 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2024-11-05 14:18:16 +0100
commit39c8faefb5e9bf1265cf754f43a17a4ac092d7a3 (patch)
tree94de4b8f674d9ad1a672bc0b1b250f3bce578e97 /rust/qemu-api/Cargo.toml
parent907d2bbb80d6180fa27a719536844fd096fa0157 (diff)
rust: create a cargo workspace
Workspaces allows tracking dependencies for multiple crates at once, by having a single Cargo.lock file at the top of the rust/ tree. Because QEMU's Cargo.lock files have to be synchronized with the versions of crates in subprojects/, using a workspace avoids the need to copy over the Cargo.lock file when adding a new device (and thus a new crate) under rust/hw/. In addition, workspaces let cargo download and build dependencies just once. While right now we have one leaf crate (hw/char/pl011), this will not be the case once more devices are added. Reviewed-by: Zhao Liu <zhao1.liu@intel.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'rust/qemu-api/Cargo.toml')
-rw-r--r--rust/qemu-api/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/rust/qemu-api/Cargo.toml b/rust/qemu-api/Cargo.toml
index db594c6408..e092f61e8f 100644
--- a/rust/qemu-api/Cargo.toml
+++ b/rust/qemu-api/Cargo.toml
@@ -20,8 +20,5 @@ qemu_api_macros = { path = "../qemu-api-macros" }
default = []
allocator = []
-# Do not include in any global workspace
-[workspace]
-
[lints.rust]
unexpected_cfgs = { level = "warn", check-cfg = ['cfg(MESON)', 'cfg(HAVE_GLIB_WITH_ALIGNED_ALLOC)'] }