aboutsummaryrefslogtreecommitdiff
path: root/migration/meson.build
diff options
context:
space:
mode:
authorSteve Sistare <steven.sistare@oracle.com>2023-09-08 07:22:10 -0700
committerJuan Quintela <quintela@redhat.com>2023-10-04 13:16:58 +0200
commit2a9e2e595f2bc81c07e2f06ef9ba7d4c68897f1c (patch)
tree9737946cbcc59a268faa9c186e3cf4e4a3eaf8dc /migration/meson.build
parentb28e3ecf0de1bc77b6a1a520e3c223f37b5afce2 (diff)
migration: file URI
Extend the migration URI to support file:<filename>. This can be used for any migration scenario that does not require a reverse path. It can be used as an alternative to 'exec:cat > file' in minimized containers that do not contain /bin/sh, and it is easier to use than the fd:<fdname> URI. It can be used in HMP commands, and as a qemu command-line parameter. For best performance, guest ram should be shared and x-ignore-shared should be true, so guest pages are not written to the file, in which case the guest may remain running. If ram is not so configured, then the user is advised to stop the guest first. Otherwise, a busy guest may re-dirty the same page, causing it to be appended to the file multiple times, and the file may grow unboundedly. That issue is being addressed in the "fixed-ram" patch series. Signed-off-by: Steve Sistare <steven.sistare@oracle.com> Tested-by: Michael Galaxy <mgalaxy@akamai.com> Reviewed-by: Michael Galaxy <mgalaxy@akamai.com> Reviewed-by: Fabiano Rosas <farosas@suse.de> Reviewed-by: Peter Xu <peterx@redhat.com> Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Reviewed-by: Juan Quintela <quintela@redhat.com> Signed-off-by: Juan Quintela <quintela@redhat.com> Message-ID: <1694182931-61390-2-git-send-email-steven.sistare@oracle.com>
Diffstat (limited to 'migration/meson.build')
-rw-r--r--migration/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/migration/meson.build b/migration/meson.build
index 1ae28523a1..92b1cc4297 100644
--- a/migration/meson.build
+++ b/migration/meson.build
@@ -16,6 +16,7 @@ system_ss.add(files(
'dirtyrate.c',
'exec.c',
'fd.c',
+ 'file.c',
'global_state.c',
'migration-hmp-cmds.c',
'migration.c',