aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2024-10-25 09:20:16 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2024-11-05 14:18:17 +0100
commitce4a144cf817d401592918faa86f4903d3c78c3e (patch)
tree8993b0d734316ea31f41b44c1752f5004bc0ca38 /meson.build
parent4fe146926fd50a9a2f5591fedc46c7aef7b4bd32 (diff)
rust: do not use --generate-cstr
--generate-cstr is a good idea and generally the right thing to do, but it is not available in Debian 12 and Ubuntu 22.04. Work around the absence. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 11d7c3464c..5b85d4275b 100644
--- a/meson.build
+++ b/meson.build
@@ -3961,13 +3961,15 @@ common_all = static_library('common',
dependencies: common_ss.all_dependencies())
if have_rust
+ # We would like to use --generate-cstr, but it is only available
+ # starting with bindgen 0.66.0. The oldest supported versions
+ # are in Ubuntu 22.04 (0.59.1) and Debian 12 (0.60.1).
bindgen_args = [
'--disable-header-comment',
'--raw-line', '// @generated',
'--ctypes-prefix', 'std::os::raw',
'--formatter', 'rustfmt',
'--generate-block',
- '--generate-cstr',
'--impl-debug',
'--merge-extern-blocks',
'--no-doc-comments',