aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2024-10-27 14:07:01 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2024-10-31 18:28:32 +0100
commit14ed29da419f2bfcf177af21348e0e3c643ac6b0 (patch)
treefecdfc1def26caf4512b98b6180a6065edf82c30 /meson.build
parent0665b3f9925ee7041e6a8eee9d1deda59a726383 (diff)
configure, meson: deprecate 32-bit MIPS
The mipsel architecture is not available in Debian Trixie, and it will likely be a hard failure as soon as we drop support for the old Rust toolchain in Debian Bookworm. Prepare by deprecating 32-bit little endian MIPS in QEMU 9.2. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f7d4517521..bae7a4370d 100644
--- a/meson.build
+++ b/meson.build
@@ -4720,6 +4720,14 @@ if host_arch == 'unknown'
message('configure has succeeded and you can continue to build, but')
message('QEMU will use a slow interpreter to emulate the target CPU.')
endif
+elif host_arch == 'mips'
+ message()
+ warning('DEPRECATED HOST CPU')
+ message()
+ message('Support for CPU host architecture ' + cpu + ' is going to be')
+ message('dropped as soon as the QEMU project stops supporting Debian 12')
+ message('("Bookworm"). Going forward, the QEMU project will not guarantee')
+ message('that QEMU will compile or work on this host CPU.')
endif
if not supported_oses.contains(host_os)