aboutsummaryrefslogtreecommitdiff
path: root/linux-user/meson.build
diff options
context:
space:
mode:
authorRichard Henderson <richard.henderson@linaro.org>2021-11-15 14:08:52 +0100
committerRichard Henderson <richard.henderson@linaro.org>2021-12-19 20:47:33 -0800
commita3310c0397e21df8f47cde3e55736104b9584d2d (patch)
tree2e550417028aea39886ba22f4b60fb9c88404630 /linux-user/meson.build
parentb9d2af3c62c22870c02410d5c9c6d097ee0ddf3f (diff)
linux-user: Move syscall error detection into safe_syscall_base
The current api from safe_syscall_base() is to return -errno, which is the interface provided by *some* linux kernel abis. The wrapper macro, safe_syscall(), detects error, stores into errno, and returns -1, to match the api of the system syscall(). For those kernel abis that do not return -errno natively, this leads to double syscall error detection. E.g. Linux ppc64, which sets the SO flag for error. Simplify the usage from C by moving the error detection into assembly, and usage from assembly by providing a C helper with which to set errno. Reviewed-by: Warner Losh <imp@bsdimp.com> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'linux-user/meson.build')
-rw-r--r--linux-user/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/linux-user/meson.build b/linux-user/meson.build
index bf62c13e37..94ac3c58ce 100644
--- a/linux-user/meson.build
+++ b/linux-user/meson.build
@@ -10,6 +10,7 @@ linux_user_ss.add(files(
'main.c',
'mmap.c',
'safe-syscall.S',
+ 'safe-syscall-error.c',
'signal.c',
'strace.c',
'syscall.c',