aboutsummaryrefslogtreecommitdiff
path: root/hw/virtio/meson.build
diff options
context:
space:
mode:
authorAlex Bennée <alex.bennee@linaro.org>2023-07-10 16:35:09 +0100
committerMichael S. Tsirkin <mst@redhat.com>2023-10-04 04:54:04 -0400
commiteee77809733d3a94c0d78a29a93d032c1faefd2c (patch)
tree857c5e00e2aff1801c844f7722b09895d50ac4ca /hw/virtio/meson.build
parentf05356f84d2e3cb4f6437716cc9b5dc59baf769d (diff)
virtio: add vhost-user-base and a generic vhost-user-device
In theory we shouldn't need to repeat so much boilerplate to support vhost-user backends. This provides a generic vhost-user-base QOM object and a derived vhost-user-device for which the user needs to provide the few bits of information that aren't currently provided by the vhost-user protocol. This should provide a baseline implementation from which the other vhost-user stub can specialise. Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Message-Id: <20230710153522.3469097-8-alex.bennee@linaro.org> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'hw/virtio/meson.build')
-rw-r--r--hw/virtio/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/hw/virtio/meson.build b/hw/virtio/meson.build
index 4e81d10834..c0055a7832 100644
--- a/hw/virtio/meson.build
+++ b/hw/virtio/meson.build
@@ -15,7 +15,10 @@ if have_vhost
system_virtio_ss.add(files('vhost.c'))
specific_virtio_ss.add(files('vhost-backend.c', 'vhost-iova-tree.c'))
if have_vhost_user
+ # fixme - this really should be generic
specific_virtio_ss.add(files('vhost-user.c'))
+ system_virtio_ss.add(files('vhost-user-device.c'))
+ system_virtio_ss.add(when: 'CONFIG_VIRTIO_PCI', if_true: files('vhost-user-device-pci.c'))
endif
if have_vhost_vdpa
system_virtio_ss.add(files('vhost-vdpa.c'))