aboutsummaryrefslogtreecommitdiff
path: root/hw/virtio/meson.build
diff options
context:
space:
mode:
authorMathieu Poirier <mathieu.poirier@linaro.org>2021-10-12 14:59:02 -0600
committerMichael S. Tsirkin <mst@redhat.com>2021-10-20 04:37:55 -0400
commit821d28b88f850e5fbc66ee62bdd155eb2d474a29 (patch)
tree05d9a58b5475b64acfc20c5d2cda7452660c99d3 /hw/virtio/meson.build
parent6889eb2d431ae962e3e083b57bff47cd573cb1c4 (diff)
vhost-user-rng: Add vhost-user-rng implementation
Introduce a random number generator (RNG) backend that communicates with a vhost-user server to retrieve entropy. That way other VMM that comply with the vhost user protocl can use the same vhost-user daemon without having to write yet another RNG driver. Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org> Message-Id: <20211012205904.4106769-2-mathieu.poirier@linaro.org> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'hw/virtio/meson.build')
-rw-r--r--hw/virtio/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/virtio/meson.build b/hw/virtio/meson.build
index bc352a6009..ae6b2cde10 100644
--- a/hw/virtio/meson.build
+++ b/hw/virtio/meson.build
@@ -27,6 +27,7 @@ virtio_ss.add(when: 'CONFIG_VIRTIO_IOMMU', if_true: files('virtio-iommu.c'))
virtio_ss.add(when: 'CONFIG_VIRTIO_MEM', if_true: files('virtio-mem.c'))
virtio_ss.add(when: 'CONFIG_VHOST_USER_I2C', if_true: files('vhost-user-i2c.c'))
virtio_ss.add(when: ['CONFIG_VIRTIO_PCI', 'CONFIG_VHOST_USER_I2C'], if_true: files('vhost-user-i2c-pci.c'))
+virtio_ss.add(when: 'CONFIG_VHOST_USER_RNG', if_true: files('vhost-user-rng.c'))
virtio_pci_ss = ss.source_set()
virtio_pci_ss.add(when: 'CONFIG_VHOST_VSOCK', if_true: files('vhost-vsock-pci.c'))