aboutsummaryrefslogtreecommitdiff
path: root/hw/nios2/meson.build
diff options
context:
space:
mode:
authorPeter Maydell <peter.maydell@linaro.org>2020-11-29 17:40:21 +0000
committerPeter Maydell <peter.maydell@linaro.org>2020-12-15 12:04:30 +0000
commit2c87548ef46040d0577cc362cab94561c1d98b8d (patch)
tree8332ce98acec8d09dbf58510e72832ccaa0ec24f /hw/nios2/meson.build
parentcd2528de2cd07d790949c1b5532ae2ab11255e1b (diff)
target/nios2: Move nios2_check_interrupts() into target/nios2
The function nios2_check_interrupts)() looks only at CPU-internal state; it belongs in target/nios2, not hw/nios2. Move it into the same file as its only caller, so it can just be local to that file. This removes the only remaining code from cpu_pic.c, so we can delete that file entirely. Signed-off-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-id: 20201129174022.26530-3-peter.maydell@linaro.org Reviewed-by: Wentong Wu <wentong.wu@intel.com> Tested-by: Wentong Wu <wentong.wu@intel.com>
Diffstat (limited to 'hw/nios2/meson.build')
-rw-r--r--hw/nios2/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/nios2/meson.build b/hw/nios2/meson.build
index dd66ebb32f..6c58e8082b 100644
--- a/hw/nios2/meson.build
+++ b/hw/nios2/meson.build
@@ -1,5 +1,5 @@
nios2_ss = ss.source_set()
-nios2_ss.add(files('boot.c', 'cpu_pic.c'))
+nios2_ss.add(files('boot.c'))
nios2_ss.add(when: 'CONFIG_NIOS2_10M50', if_true: files('10m50_devboard.c'))
nios2_ss.add(when: 'CONFIG_NIOS2_GENERIC_NOMMU', if_true: files('generic_nommu.c'))