aboutsummaryrefslogtreecommitdiff
path: root/chardev/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-11-30 13:44:49 -0500
committerPaolo Bonzini <pbonzini@redhat.com>2020-12-15 12:51:51 -0500
commit5a1ee6077b89ee9a803aaf8d1c98004701f63684 (patch)
treeff3c0d5a2fc247b49974c38e2ccd9a1902a08b3f /chardev/meson.build
parentf66dc8737c94a0ab57a252a280e5e83d6d630c67 (diff)
chardev: do not use machine_init_done
machine_init_done is not the right flag to check when preconfig is taken into account; for example "./qemu-system-x86_64 -serial mon:stdio -preconfig" does not print the QEMU monitor header until after exit_preconfig. Add back a custom bool for mux character devices. This partially undoes commit c7278b4355 ("chardev: introduce chr_machine_done hook", 2018-03-12), but it keeps the cleaner logic using a function pointer in ChardevClass. Reviewed-by: Igor Mammedov <imammedo@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'chardev/meson.build')
-rw-r--r--chardev/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/chardev/meson.build b/chardev/meson.build
index 859d8b04d4..4e19722c5e 100644
--- a/chardev/meson.build
+++ b/chardev/meson.build
@@ -25,7 +25,7 @@ chardev_ss.add(when: 'CONFIG_WIN32', if_true: files(
chardev_ss = chardev_ss.apply(config_host, strict: false)
-softmmu_ss.add(files('chardev-sysemu.c', 'msmouse.c', 'wctablet.c', 'testdev.c'))
+softmmu_ss.add(files('msmouse.c', 'wctablet.c', 'testdev.c'))
chardev_modules = {}