aboutsummaryrefslogtreecommitdiff
path: root/block/meson.build
diff options
context:
space:
mode:
authorVladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>2023-04-21 12:27:58 +0300
committerKevin Wolf <kwolf@redhat.com>2023-05-10 14:15:13 +0200
commit11cea42e176bebc5e85866b01ade4a86651b7633 (patch)
treefcbe48952e0a32321b38c24269aab55331e5e5f4 /block/meson.build
parentb2896c1b09878fd1c4b485b3662f8beecbe0fef4 (diff)
block: add configure options for excluding vmdk, vhdx and vpc
Let's add --enable / --disable configure options for these formats, so that those who don't need them may not build them. Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru> Message-Id: <20230421092758.814122-1-vsementsov@yandex-team.ru> Reviewed-by: Kevin Wolf <kwolf@redhat.com> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
Diffstat (limited to 'block/meson.build')
-rw-r--r--block/meson.build18
1 files changed, 13 insertions, 5 deletions
diff --git a/block/meson.build b/block/meson.build
index 382bec0e7d..13337bd070 100644
--- a/block/meson.build
+++ b/block/meson.build
@@ -38,11 +38,6 @@ block_ss.add(files(
'snapshot-access.c',
'throttle-groups.c',
'throttle.c',
- 'vhdx-endian.c',
- 'vhdx-log.c',
- 'vhdx.c',
- 'vmdk.c',
- 'vpc.c',
'write-threshold.c',
), zstd, zlib, gnutls)
@@ -55,6 +50,19 @@ endif
if get_option('vdi').allowed()
block_ss.add(files('vdi.c'))
endif
+if get_option('vhdx').allowed()
+ block_ss.add(files(
+ 'vhdx-endian.c',
+ 'vhdx-log.c',
+ 'vhdx.c'
+ ))
+endif
+if get_option('vmdk').allowed()
+ block_ss.add(files('vmdk.c'))
+endif
+if get_option('vpc').allowed()
+ block_ss.add(files('vpc.c'))
+endif
if get_option('cloop').allowed()
block_ss.add(files('cloop.c'))
endif