aboutsummaryrefslogtreecommitdiff
path: root/src/util/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/CMakeLists.txt')
-rw-r--r--src/util/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/util/CMakeLists.txt b/src/util/CMakeLists.txt
new file mode 100644
index 0000000000..4999dbf13f
--- /dev/null
+++ b/src/util/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Copyright (c) 2023-present The Bitcoin Core developers
+# Distributed under the MIT software license, see the accompanying
+# file COPYING or https://opensource.org/license/mit/.
+
+add_library(bitcoin_util STATIC EXCLUDE_FROM_ALL
+ asmap.cpp
+ batchpriority.cpp
+ bip32.cpp
+ bytevectorhash.cpp
+ chaintype.cpp
+ check.cpp
+ exception.cpp
+ feefrac.cpp
+ fs.cpp
+ fs_helpers.cpp
+ hasher.cpp
+ moneystr.cpp
+ rbf.cpp
+ readwritefile.cpp
+ serfloat.cpp
+ signalinterrupt.cpp
+ sock.cpp
+ strencodings.cpp
+ string.cpp
+ syserror.cpp
+ thread.cpp
+ threadinterrupt.cpp
+ threadnames.cpp
+ time.cpp
+ tokenpipe.cpp
+ ../logging.cpp
+ ../random.cpp
+ ../randomenv.cpp
+ ../streams.cpp
+ ../support/lockedpool.cpp
+ ../sync.cpp
+)
+
+target_link_libraries(bitcoin_util
+ PRIVATE
+ core_interface
+ bitcoin_clientversion
+ bitcoin_crypto
+ $<$<PLATFORM_ID:Windows>:ws2_32>
+ $<$<PLATFORM_ID:Windows>:iphlpapi>
+)