aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f5cf8cbca5..592f06aec6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -133,6 +133,7 @@ BITCOIN_CORE_H = \
clientversion.h \
coins.h \
common/bloom.h \
+ common/run_command.h \
compat/assumptions.h \
compat/byteswap.h \
compat/compat.h \
@@ -284,7 +285,6 @@ BITCOIN_CORE_H = \
util/rbf.h \
util/readwritefile.h \
util/result.h \
- util/run_command.h \
util/serfloat.h \
util/settings.h \
util/sock.h \
@@ -617,7 +617,7 @@ libbitcoin_consensus_a_SOURCES = \
version.h
# common: shared between bitcoind, and bitcoin-qt and non-server tools
-libbitcoin_common_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
+libbitcoin_common_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(BOOST_CPPFLAGS)
libbitcoin_common_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_common_a_SOURCES = \
base58.cpp \
@@ -625,6 +625,7 @@ libbitcoin_common_a_SOURCES = \
chainparams.cpp \
coins.cpp \
common/bloom.cpp \
+ common/run_command.cpp \
compressor.cpp \
core_read.cpp \
core_write.cpp \
@@ -681,7 +682,6 @@ libbitcoin_util_a_SOURCES = \
util/fees.cpp \
util/getuniquepath.cpp \
util/hasher.cpp \
- util/run_command.cpp \
util/sock.cpp \
util/syserror.cpp \
util/system.cpp \