aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/native_boost.mk
diff options
context:
space:
mode:
Diffstat (limited to 'depends/packages/native_boost.mk')
-rw-r--r--depends/packages/native_boost.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/depends/packages/native_boost.mk b/depends/packages/native_boost.mk
new file mode 100644
index 0000000000..b9e6253772
--- /dev/null
+++ b/depends/packages/native_boost.mk
@@ -0,0 +1,13 @@
+package=native_boost
+$(package)_version=$(boost_version)
+$(package)_download_path=$(boost_download_path)
+$(package)_file_name=$(boost_file_name)
+$(package)_sha256_hash=$(boost_sha256_hash)
+
+define $(package)_config_cmds
+ ./bootstrap.sh --prefix=$($($(package)_type)_prefix) --with-libraries=headers
+endef
+
+define $(package)_stage_cmds
+ ./b2 -d0 --prefix=$($(package)_staging_prefix_dir) install
+endef