aboutsummaryrefslogtreecommitdiff
path: root/src/univalue/CMakeLists.txt
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-01-09 18:00:58 +0000
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2024-08-16 19:27:38 +0100
commit958971f476a29cb5bb76f3ae80ae968317ca1930 (patch)
tree21b381f95e852afba68901861302b3edb5a50cf3 /src/univalue/CMakeLists.txt
parent752747fda801f2c0ecce91c96bcc9ef93e27462b (diff)
downloadbitcoin-958971f476a29cb5bb76f3ae80ae968317ca1930.tar.xz
cmake: Build `univalue` static library
Diffstat (limited to 'src/univalue/CMakeLists.txt')
-rw-r--r--src/univalue/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/univalue/CMakeLists.txt b/src/univalue/CMakeLists.txt
new file mode 100644
index 0000000000..ef7f7362f9
--- /dev/null
+++ b/src/univalue/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Copyright (c) 2023-present The Bitcoin Core developers
+# Distributed under the MIT software license, see the accompanying
+# file COPYING or https://opensource.org/license/mit/.
+
+add_library(univalue STATIC EXCLUDE_FROM_ALL
+ lib/univalue.cpp
+ lib/univalue_get.cpp
+ lib/univalue_read.cpp
+ lib/univalue_write.cpp
+)
+target_include_directories(univalue
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+)
+target_link_libraries(univalue PRIVATE core_interface)