aboutsummaryrefslogtreecommitdiff
path: root/src/secp256k1/CMakeLists.txt
diff options
context:
space:
mode:
authorPieter Wuille <pieter@wuille.net>2023-09-04 12:51:20 -0400
committerPieter Wuille <pieter@wuille.net>2023-09-04 12:51:20 -0400
commit0e0fc18c3cf8c0aa4cca85c4294416463f157870 (patch)
tree9ea54b2a529bdcf5b380ac54e7894f9aac949eaa /src/secp256k1/CMakeLists.txt
parent6f03c45f6bb5a6edaa3051968b6a1ca4f84d2ccb (diff)
parentc0da4f60e2145a9838c0c5d0a02592faf16d2d8d (diff)
downloadbitcoin-0e0fc18c3cf8c0aa4cca85c4294416463f157870.tar.xz
Update secp256k1 subtree to upstream release 0.4.0
Diffstat (limited to 'src/secp256k1/CMakeLists.txt')
-rw-r--r--src/secp256k1/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/secp256k1/CMakeLists.txt b/src/secp256k1/CMakeLists.txt
index 3107eb3bf1..cdac47ba9d 100644
--- a/src/secp256k1/CMakeLists.txt
+++ b/src/secp256k1/CMakeLists.txt
@@ -11,7 +11,7 @@ project(libsecp256k1
# The package (a.k.a. release) version is based on semantic versioning 2.0.0 of
# the API. All changes in experimental modules are treated as
# backwards-compatible and therefore at most increase the minor version.
- VERSION 0.3.3
+ VERSION 0.4.0
DESCRIPTION "Optimized C library for ECDSA signatures and secret/public key operations on curve secp256k1."
HOMEPAGE_URL "https://github.com/bitcoin-core/secp256k1"
LANGUAGES C
@@ -34,9 +34,9 @@ endif()
# https://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
# All changes in experimental modules are treated as if they don't affect the
# interface and therefore only increase the revision.
-set(${PROJECT_NAME}_LIB_VERSION_CURRENT 2)
-set(${PROJECT_NAME}_LIB_VERSION_REVISION 3)
-set(${PROJECT_NAME}_LIB_VERSION_AGE 0)
+set(${PROJECT_NAME}_LIB_VERSION_CURRENT 3)
+set(${PROJECT_NAME}_LIB_VERSION_REVISION 0)
+set(${PROJECT_NAME}_LIB_VERSION_AGE 1)
set(CMAKE_C_STANDARD 90)
set(CMAKE_C_EXTENSIONS OFF)