aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMacroFake <falke.marco@gmail.com>2022-08-02 15:30:00 +0200
committerMacroFake <falke.marco@gmail.com>2022-08-02 15:31:01 +0200
commitfac812ca835e0d843aba1d4db0e49d183018a29e (patch)
treeee5a6c99ad4f05318fe3cadfe6e1e27474343033 /src/Makefile.am
parent66664384a6fec39ecb4d8d06db66a4f193a06e33 (diff)
downloadbitcoin-fac812ca835e0d843aba1d4db0e49d183018a29e.tar.xz
scripted-diff: Move mempool_args to src/node
It is part of the node library. Also, it won't be moved to the kernel lib, as it will be pruned of ArgsManager. -BEGIN VERIFY SCRIPT- # Move module git mv src/mempool_args.cpp src/node/ git mv src/mempool_args.h src/node/ # Replacements sed -i 's:mempool_args\.h:node/mempool_args.h:g' $(git grep -l mempool_args) sed -i 's:mempool_args\.cpp:node/mempool_args.cpp:g' $(git grep -l mempool_args) sed -i 's:MEMPOOL_ARGS_H:NODE_MEMPOOL_ARGS_H:g' $(git grep -l MEMPOOL_ARGS_H) -END VERIFY SCRIPT-
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 23bc180095..1da6199137 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -184,7 +184,7 @@ BITCOIN_CORE_H = \
logging.h \
logging/timer.h \
mapport.h \
- mempool_args.h \
+ node/mempool_args.h \
memusage.h \
merkleblock.h \
net.h \
@@ -372,7 +372,7 @@ libbitcoin_node_a_SOURCES = \
kernel/context.cpp \
kernel/mempool_persist.cpp \
mapport.cpp \
- mempool_args.cpp \
+ node/mempool_args.cpp \
net.cpp \
netgroup.cpp \
net_processing.cpp \