aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBen Woosley <ben.woosley@gmail.com>2023-03-06 17:22:33 +0100
committerTheCharlatan <seb.kung@gmail.com>2023-03-13 17:09:47 +0100
commite7333b420e35054d9302f9c58fd47b6152cbd35f (patch)
treeb7dd521363eeedcc4e2f353624facbe8cc679372 /src/Makefile.am
parentf7bdcfc83f5753349018be3b5a663c8923d1a5eb (diff)
downloadbitcoin-e7333b420e35054d9302f9c58fd47b6152cbd35f.tar.xz
refactor: Extract util/exception from util/system
This is a minimal extraction of a single function, but also the only use of std::exception in util/system. The background of this commit is an ongoing effort to decouple the libbitcoinkernel library from the ArgsManager defined in system.h. Moving the function out of system.h allows including it from a separate source file without including the ArgsManager definitions from system.h.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7dc5594cf2..a0c1670287 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -279,6 +279,7 @@ BITCOIN_CORE_H = \
util/check.h \
util/epochguard.h \
util/error.h \
+ util/exception.h \
util/fastrange.h \
util/fees.h \
util/getuniquepath.h \
@@ -699,6 +700,7 @@ libbitcoin_util_a_SOURCES = \
util/bytevectorhash.cpp \
util/check.cpp \
util/error.cpp \
+ util/exception.cpp \
util/fees.cpp \
util/getuniquepath.cpp \
util/hasher.cpp \
@@ -942,6 +944,7 @@ libbitcoinkernel_la_SOURCES = \
txmempool.cpp \
uint256.cpp \
util/check.cpp \
+ util/exception.cpp \
util/getuniquepath.cpp \
util/hasher.cpp \
util/moneystr.cpp \