aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2019-08-28 15:12:51 -0700
committerPieter Wuille <pieter.wuille@gmail.com>2019-10-16 08:56:57 -0700
commite65e61c812df90a56e3ce4a8e76c4b746766f387 (patch)
tree787fa4b641ed0d640f96cf430092961e9d7b1b20 /src/Makefile.am
parentc34b88620dc8435b83e6744895f2ecd3c9ec8de7 (diff)
downloadbitcoin-e65e61c812df90a56e3ce4a8e76c4b746766f387.tar.xz
Add some general std::vector utility functions
Added are: * Vector(arg1,arg2,arg3,...) constructs a vector with the specified arguments as elements. The vector's type is derived from the arguments. If some of the arguments are rvalue references, they will be moved into place rather than copied (which can't be achieved using list initialization). * Cat(vector1,vector2) returns a concatenation of the two vectors, efficiently moving elements when relevant. Vector generalizes (and replaces) the Singleton function in src/descriptor.cpp, and Cat replaces the Cat function in bech32.cpp
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eec84122ae..d50524a8ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -220,6 +220,7 @@ BITCOIN_CORE_H = \
util/translation.h \
util/url.h \
util/validation.h \
+ util/vector.h \
validation.h \
validationinterface.h \
versionbits.h \