aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-06-27 16:50:44 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2017-06-29 12:02:43 +0200
commitdf7e2f057b6c9f0f7c950f9077dc63a577f54117 (patch)
tree15eb622e97f335d74ceebc2583dbcd0ca5ffa4fe /src/Makefile.am
parentac52492cd22782d7b09c78c198fb6fd8eb1da57c (diff)
downloadbitcoin-df7e2f057b6c9f0f7c950f9077dc63a577f54117.tar.xz
rpc: Move the `generate` RPC call to rpcwallet
This makes it possible to mine to any wallet when multi-wallet mode is added. Solves the same problem as #10649, but IMO in a cleaner way. It also gets rid of the circuitous `ScriptForMining` method on `CValidationInterface`, which really doesn't belong there. After this change it's still possible to mine without wallet through `generatetoaddress`.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9b9dd89f68..8ecd391804 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -127,6 +127,7 @@ BITCOIN_CORE_H = \
reverselock.h \
rpc/blockchain.h \
rpc/client.h \
+ rpc/mining.h \
rpc/protocol.h \
rpc/server.h \
rpc/register.h \