aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2016-04-16 00:13:15 -0400
committerCory Fields <cory-nospam-@coryfields.com>2016-09-08 12:03:22 -0400
commitd93b14dc5ddfb937b0cc18be425b9d048cefb66b (patch)
tree34ef01ca454822012869ee98a81189b79802c6d5 /src/Makefile.am
parent531214fb100c14e62921085cd68cabe2b20ee0eb (diff)
downloadbitcoin-d93b14dc5ddfb937b0cc18be425b9d048cefb66b.tar.xz
net: move CBanDB and CAddrDB out of net.h/cpp
This will eventually solve a circular dependency
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 03fac5bf97..ebdddc87f5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -71,6 +71,7 @@ endif
.PHONY: FORCE check-symbols check-security
# bitcoin core #
BITCOIN_CORE_H = \
+ addrdb.h \
addrman.h \
base58.h \
bloom.h \
@@ -164,6 +165,7 @@ libbitcoin_server_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES) $(MINIUPNPC_CP
libbitcoin_server_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_server_a_SOURCES = \
addrman.cpp \
+ addrdb.cpp \
bloom.cpp \
blockencodings.cpp \
chain.cpp \