aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2023-04-17 21:55:17 +0200
committerTheCharlatan <seb.kung@gmail.com>2023-05-09 11:33:09 +0200
commitbfc21c31b2186f7d30fc9a9ca7d6887ab61c6fb9 (patch)
tree250239b4f93bc9882eb3051d238b0792357a2a01 /src/Makefile.am
parent322ec63b01499c1ec52d3912ee382ebd59f2366b (diff)
downloadbitcoin-bfc21c31b2186f7d30fc9a9ca7d6887ab61c6fb9.tar.xz
refactor: Create chaintype files
This is the first of a number of commits with the goal of moving the chain type definitions out of chainparamsbase to their own file and implementing them as enums instead of constant strings. The goal is to allow the kernel chainparams to no longer include chainparamsbase. The commit is part of an ongoing effort to decouple the libbitcoinkernel library from the ArgsManager and other functionality that should not be part of the kernel library.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d12edca64e..9e1fab869d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -280,6 +280,7 @@ BITCOIN_CORE_H = \
util/bip32.h \
util/bitdeque.h \
util/bytevectorhash.h \
+ util/chaintype.h \
util/check.h \
util/epochguard.h \
util/error.h \
@@ -707,6 +708,7 @@ libbitcoin_util_a_SOURCES = \
util/asmap.cpp \
util/bip32.cpp \
util/bytevectorhash.cpp \
+ util/chaintype.cpp \
util/check.cpp \
util/error.cpp \
util/exception.cpp \
@@ -956,6 +958,7 @@ libbitcoinkernel_la_SOURCES = \
txdb.cpp \
txmempool.cpp \
uint256.cpp \
+ util/chaintype.cpp \
util/check.cpp \
util/exception.cpp \
util/fs.cpp \