aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2023-05-06 22:14:11 +0200
committerTheCharlatan <seb.kung@gmail.com>2023-05-20 12:03:30 +0200
commit9ec5da36b62276ae22e348f26f88aaf646357d6d (patch)
tree5bd3bfc21492d1db0bfe0e4f0452f64f593fad16 /src/Makefile.am
parentf871c69191dfe1331861ebcdbadb6bd47e45c8b1 (diff)
downloadbitcoin-9ec5da36b62276ae22e348f26f88aaf646357d6d.tar.xz
refactor: Move ScheduleBatchPriority to its own file
With the previous move of AlertNotify out of the validation file, and thus out of the kernel library, ScheduleBatchPriority is the last remaining function used by the kernel library from util/system. Move it to its own file, such that util/system can be moved out of the util library in the following few commits. Moving util/system out of the kernel library removes further networking as well as shell related code from it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2bbd343657..9764df7fbc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -280,6 +280,7 @@ BITCOIN_CORE_H = \
txrequest.h \
undo.h \
util/asmap.h \
+ util/batchpriority.h \
util/bip32.h \
util/bitdeque.h \
util/bytevectorhash.h \
@@ -711,6 +712,7 @@ libbitcoin_util_a_SOURCES = \
support/cleanse.cpp \
sync.cpp \
util/asmap.cpp \
+ util/batchpriority.cpp \
util/bip32.cpp \
util/bytevectorhash.cpp \
util/chaintype.cpp \
@@ -963,6 +965,7 @@ libbitcoinkernel_la_SOURCES = \
txdb.cpp \
txmempool.cpp \
uint256.cpp \
+ util/batchpriority.cpp \
util/chaintype.cpp \
util/check.cpp \
util/exception.cpp \
@@ -978,7 +981,6 @@ libbitcoinkernel_la_SOURCES = \
util/string.cpp \
util/syscall_sandbox.cpp \
util/syserror.cpp \
- util/system.cpp \
util/thread.cpp \
util/threadnames.cpp \
util/time.cpp \