aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRussell Yanofsky <russ@yanofsky.org>2019-03-05 16:07:48 -0500
committerRussell Yanofsky <russ@yanofsky.org>2019-11-07 22:08:22 -0500
commit9dcb952fe5f85529ab28e091af7534e72c21c90f (patch)
tree57731a54ac2cc59fa737f329bb1359793f464f80 /src/Makefile.am
parente2e37cfe8af088bd8ea884be2f79f0f3cac555d5 (diff)
downloadbitcoin-9dcb952fe5f85529ab28e091af7534e72c21c90f.tar.xz
Add util::Settings struct and helper functions.
Implement merging of settings from different sources (command line and config file) separately from parsing code in system.cpp, so it is easier to add new sources. Document current inconsistent merging behavior without changing it. This commit only adds new settings code without using it. The next commit calls the new code to replace existing code in system.cpp. Co-authored-by: John Newbery <john@johnnewbery.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff4f071a3c..a14e44d2c0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -219,6 +219,7 @@ BITCOIN_CORE_H = \
util/memory.h \
util/moneystr.h \
util/rbf.h \
+ util/settings.h \
util/string.h \
util/threadnames.h \
util/time.h \
@@ -513,6 +514,7 @@ libbitcoin_util_a_SOURCES = \
util/system.cpp \
util/moneystr.cpp \
util/rbf.cpp \
+ util/settings.cpp \
util/threadnames.cpp \
util/spanparsing.cpp \
util/strencodings.cpp \