aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2017-08-25 18:12:39 -0700
committerPieter Wuille <pieter.wuille@gmail.com>2017-09-28 16:02:16 -0700
commit8fd226705347c2b3955d0d98f8ca21e4325e6765 (patch)
tree0a5e9d0e14fddb614700a06d00cd5ae23955780a /src/Makefile.am
parent1e46ebdf8618e585568ffc1b093c79cc9be07b57 (diff)
downloadbitcoin-8fd226705347c2b3955d0d98f8ca21e4325e6765.tar.xz
Import Bech32 C++ reference code & tests
This includes a reformatted version of the Bech32 reference code (see https://github.com/sipa/bech32/tree/master/ref/c%2B%2B), with extra documentation.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ebae53a8c1..c71e457ebe 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,6 +78,7 @@ BITCOIN_CORE_H = \
addrdb.h \
addrman.h \
base58.h \
+ bech32.h \
bloom.h \
blockencodings.h \
chain.h \
@@ -316,6 +317,7 @@ libbitcoin_common_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_common_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_common_a_SOURCES = \
base58.cpp \
+ bech32.cpp \
chainparams.cpp \
coins.cpp \
compressor.cpp \