aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRyan Ofsky <ryan@ofsky.org>2022-10-11 23:35:28 -0400
committerRyan Ofsky <ryan@ofsky.org>2022-11-29 08:12:24 -0400
commit82e272a109281f750909d1feade784c778d8b592 (patch)
treede882a0536469dc9990644d2c9079a33fd7c778a /src/Makefile.am
parenta035b6a0c418d0b720707df69559028bd662fa70 (diff)
downloadbitcoin-82e272a109281f750909d1feade784c778d8b592.tar.xz
refactor: Move src/interfaces/*.cpp files to libbitcoin_common.a
These belong in libbitcoin_common.a, not libbitcoin_util.a, because they aren't general-purpose utilities, they just contain common code that is used by both the node and the wallet. Another reason to reason to not include these in libbitcoin_util.a is to prevent them from being used by the kernel library.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2e2da54b2d..63a690d49f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -633,6 +633,7 @@ libbitcoin_common_a_SOURCES = \
chainparams.cpp \
coins.cpp \
common/bloom.cpp \
+ common/interfaces.cpp \
common/run_command.cpp \
compressor.cpp \
core_read.cpp \
@@ -678,9 +679,6 @@ libbitcoin_util_a_SOURCES = \
chainparamsbase.cpp \
clientversion.cpp \
fs.cpp \
- interfaces/echo.cpp \
- interfaces/handler.cpp \
- interfaces/init.cpp \
logging.cpp \
random.cpp \
randomenv.cpp \