aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-11-16 20:16:07 +0000
committerHennadii Stepanov <32963518+hebasto@users.noreply.github.com>2022-11-16 20:16:07 +0000
commit75bbe594e54402ed248ecf2bdfe54e8283d20fff (patch)
tree598371c0342347d08cc4f19a6058a3c1d2adb520 /src/Makefile.am
parent3f1f5f6f1ec49d0fb2acfddec4021b3582ba0553 (diff)
downloadbitcoin-75bbe594e54402ed248ecf2bdfe54e8283d20fff.tar.xz
refactor: Move `CTxMemPoolEntry` class to its own module
This change nukes the policy/fees->mempool circular dependency. Easy to review using `diff --color-moved=dimmed-zebra`.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 88c62d5177..c3790cd22e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -261,6 +261,7 @@ BITCOIN_CORE_H = \
torcontrol.h \
txdb.h \
txmempool.h \
+ txmempool_entry.h \
txorphanage.h \
txrequest.h \
undo.h \
@@ -425,6 +426,7 @@ libbitcoin_node_a_SOURCES = \
torcontrol.cpp \
txdb.cpp \
txmempool.cpp \
+ txmempool_entry.cpp \
txorphanage.cpp \
txrequest.cpp \
validation.cpp \
@@ -930,6 +932,7 @@ libbitcoinkernel_la_SOURCES = \
threadinterrupt.cpp \
txdb.cpp \
txmempool.cpp \
+ txmempool_entry.cpp \
uint256.cpp \
util/check.cpp \
util/getuniquepath.cpp \