aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRyan Ofsky <ryan@ofsky.org>2022-05-25 11:40:51 -0400
committerRyan Ofsky <ryan@ofsky.org>2022-05-25 11:40:51 -0400
commit6e1c16c1442ab30694a3668b45af5bfd532f1e12 (patch)
tree8e42643d1c9f4da8cc15bdcc319125f9bb9db9e8 /src/Makefile.am
parent90e49c1ececd6296c6ec6109cea525a208c0626e (diff)
downloadbitcoin-6e1c16c1442ab30694a3668b45af5bfd532f1e12.tar.xz
multiprocess build fix: ipc/capnp/init.capnp.h: No such file or directory
Error was reported by SatoriHoshiAiko in https://github.com/bitcoin/bitcoin/issues/25207 and happens unpredictably because make doesn't always build dependencies in the same order. The source file src/ipc/capnp/protocol.cpp includes some generated headers so needs to have an explicit dependency specified in the makefile so the headers will be generated before the file is compiled. #19160 added the explicit dependency, but it was incorrect because it referred to an old file path from before the source file was renamed (ipc.cpp -> protocol.cpp)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7f82d188f0..0f72182f23 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -330,7 +330,7 @@ obj/build.h: FORCE
"$(abs_top_srcdir)"
libbitcoin_util_a-clientversion.$(OBJEXT): obj/build.h
-ipc/capnp/libbitcoin_ipc_a-ipc.$(OBJEXT): $(libbitcoin_ipc_mpgen_input:=.h)
+ipc/capnp/libbitcoin_ipc_a-protocol.$(OBJEXT): $(libbitcoin_ipc_mpgen_input:=.h)
# server: shared between bitcoind and bitcoin-qt
# Contains code accessing mempool and chain state that is meant to be separated