aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2016-03-30 15:37:41 +0200
committerPieter Wuille <pieter.wuille@gmail.com>2016-05-13 10:22:54 +0200
commit6bec172eb95e195847bb6dd6d4e62ada79c98c6d (patch)
tree741f48e6f1aeaa04652605d732a6ee8ae4b248ae /src/Makefile.am
parentcd2be4419e9d8c6445fecc877b50198dc918a81f (diff)
downloadbitcoin-6bec172eb95e195847bb6dd6d4e62ada79c98c6d.tar.xz
Add ctaes-based constant time AES implementation
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3c056386fa..0ab0d66ac2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -225,6 +225,8 @@ libbitcoin_wallet_a_SOURCES = \
crypto_libbitcoin_crypto_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_CONFIG_INCLUDES)
crypto_libbitcoin_crypto_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
crypto_libbitcoin_crypto_a_SOURCES = \
+ crypto/aes.cpp \
+ crypto/aes.h \
crypto/common.h \
crypto/hmac_sha256.cpp \
crypto/hmac_sha256.h \
@@ -434,7 +436,7 @@ CLEANFILES += zmq/*.gcda zmq/*.gcno
DISTCLEANFILES = obj/build.h
-EXTRA_DIST = leveldb
+EXTRA_DIST = leveldb crypto/ctaes
clean-local:
-$(MAKE) -C leveldb clean