aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorglozow <gloriajzhao@gmail.com>2022-08-04 15:37:50 +0100
committerMurch <murch@murch.one>2023-03-30 17:03:04 -0400
commit59afcc83548ea67a863dac7b75d000bc8f6a7023 (patch)
tree705f187a3f8300c3202751ac35b76ce67e7a1b4e /src/Makefile.am
parent56484f0fdc44261e723563f59df886d5acdd851f (diff)
downloadbitcoin-59afcc83548ea67a863dac7b75d000bc8f6a7023.tar.xz
Implement Mini version of BlockAssembler to calculate mining scores
Rewrite the same algo instead of reusing BlockAssembler because we have a few extra requirements that would make the changes invasive and difficult to review: - Only operate on the relevant transactions rather than full mempool - Remove transactions that will be replaced so they can't bump their ancestors - Don't hold mempool lock outside of the constructor - Skip things like max block weight and IsFinalTx - Additionally calculate fees to bump remaining ancestor packages to target feerate Co-authored-by: Murch <murch@murch.one>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5830090ada..3f68ac03f0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -211,6 +211,7 @@ BITCOIN_CORE_H = \
node/mempool_args.h \
node/mempool_persist_args.h \
node/miner.h \
+ node/mini_miner.h \
node/minisketchwrapper.h \
node/psbt.h \
node/transaction.h \
@@ -396,6 +397,7 @@ libbitcoin_node_a_SOURCES = \
node/mempool_args.cpp \
node/mempool_persist_args.cpp \
node/miner.cpp \
+ node/mini_miner.cpp \
node/minisketchwrapper.cpp \
node/psbt.cpp \
node/transaction.cpp \