aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJorge Timón <jtimon@jtimon.cc>2015-11-24 06:26:15 +0100
committerJorge Timón <jtimon@jtimon.cc>2015-12-08 06:31:01 +0100
commit4feadec98e0b610d1272c398505e41962218bc4f (patch)
treeecc892daff4f98e47dd1063f168aa11299526b7f /src/Makefile.am
parenta3d5eec54613044fc149445cc8e544a350ed312e (diff)
downloadbitcoin-4feadec98e0b610d1272c398505e41962218bc4f.tar.xz
Build: Libconsensus: Move libconsensus-ready files to the consensus package
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index af34ed7a93..502bbd8311 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -83,7 +83,6 @@ endif
BITCOIN_CORE_H = \
addrman.h \
alert.h \
- arith_uint256.h \
base58.h \
bloom.h \
chain.h \
@@ -101,9 +100,6 @@ BITCOIN_CORE_H = \
compat/sanity.h \
compressor.h \
consensus/consensus.h \
- consensus/merkle.h \
- consensus/params.h \
- consensus/validation.h \
core_io.h \
core_memusage.h \
httprpc.h \
@@ -124,7 +120,6 @@ BITCOIN_CORE_H = \
policy/fees.h \
policy/policy.h \
pow.h \
- primitives/block.h \
protocol.h \
random.h \
reverselock.h \
@@ -254,9 +249,17 @@ libbitcoin_consensus_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_consensus_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_consensus_a_SOURCES = \
amount.h \
+ arith_uint256.cpp \
+ arith_uint256.h \
+ consensus/merkle.cpp \
+ consensus/merkle.h \
+ consensus/params.h \
+ consensus/validation.h \
hash.cpp \
hash.h \
prevector.h \
+ primitives/block.cpp \
+ primitives/block.h \
primitives/transaction.cpp \
primitives/transaction.h \
pubkey.cpp \
@@ -281,18 +284,15 @@ libbitcoin_common_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_common_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_common_a_SOURCES = \
amount.cpp \
- arith_uint256.cpp \
base58.cpp \
chainparams.cpp \
coins.cpp \
compressor.cpp \
- consensus/merkle.cpp \
core_read.cpp \
core_write.cpp \
key.cpp \
keystore.cpp \
netbase.cpp \
- primitives/block.cpp \
protocol.cpp \
scheduler.cpp \
script/sign.cpp \