aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGleb Naumenko <naumenko.gs@gmail.com>2022-09-19 17:31:01 +0300
committerGleb Naumenko <naumenko.gs@gmail.com>2022-10-17 12:35:43 +0300
commit3fcf78ee6ab59d1a539fdf54bbae21b5d29caea9 (patch)
tree0d4160cebca85e9eb323773b42280748cc16985a /src/Makefile.am
parent24e36fac0a86aa371046470dc4f8dfed7a868fb2 (diff)
downloadbitcoin-3fcf78ee6ab59d1a539fdf54bbae21b5d29caea9.tar.xz
p2p: Announce reconciliation support
If we're connecting to the peer which might support transaction reconciliation, we announce we want to reconcile with them. We store the reconciliation salt so that when the peer responds with their salt, we are able to compute the full reconciliation salt. This behavior is enabled with a CLI flag.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 88c62d5177..5347aa5dde 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -209,6 +209,7 @@ BITCOIN_CORE_H = \
node/minisketchwrapper.h \
node/psbt.h \
node/transaction.h \
+ node/txreconciliation.h \
node/utxo_snapshot.h \
node/validation_cache_args.h \
noui.h \
@@ -396,6 +397,7 @@ libbitcoin_node_a_SOURCES = \
node/minisketchwrapper.cpp \
node/psbt.cpp \
node/transaction.cpp \
+ node/txreconciliation.cpp \
node/utxo_snapshot.cpp \
node/validation_cache_args.cpp \
noui.cpp \