aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-10-14 13:55:53 +0800
committerfanquake <fanquake@gmail.com>2022-10-31 10:17:04 +0000
commit3a0b352c63db543833e0f919a004cf2c5093fe9c (patch)
tree039448fe79ddaa2b74cc23629238f01ee181523e /src/Makefile.am
parent058eb69ce47c17205a41fc667ce66429f09a332a (diff)
downloadbitcoin-3a0b352c63db543833e0f919a004cf2c5093fe9c.tar.xz
refactor: move url.h/cpp from lib util to lib common
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 19b131a5f4..d50247b52f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -134,6 +134,7 @@ BITCOIN_CORE_H = \
coins.h \
common/bloom.h \
common/run_command.h \
+ common/url.h \
compat/assumptions.h \
compat/byteswap.h \
compat/compat.h \
@@ -303,7 +304,6 @@ BITCOIN_CORE_H = \
util/translation.h \
util/types.h \
util/ui_change_type.h \
- util/url.h \
util/vector.h \
validation.h \
validationinterface.h \
@@ -662,6 +662,11 @@ libbitcoin_common_a_SOURCES = \
script/standard.cpp \
warnings.cpp \
$(BITCOIN_CORE_H)
+
+if USE_LIBEVENT
+libbitcoin_common_a_CPPFLAGS += $(EVENT_CFLAGS)
+libbitcoin_common_a_SOURCES += common/url.cpp
+endif
#
# util #
@@ -708,11 +713,6 @@ libbitcoin_util_a_SOURCES = \
util/time.cpp \
util/tokenpipe.cpp \
$(BITCOIN_CORE_H)
-
-if USE_LIBEVENT
-libbitcoin_util_a_CPPFLAGS += $(EVENT_CFLAGS)
-libbitcoin_util_a_SOURCES += util/url.cpp
-endif
#
# cli #
@@ -776,6 +776,7 @@ endif
bitcoin_cli_LDADD = \
$(LIBBITCOIN_CLI) \
$(LIBUNIVALUE) \
+ $(LIBBITCOIN_COMMON) \
$(LIBBITCOIN_UTIL) \
$(LIBBITCOIN_CRYPTO)