aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMacroFake <falke.marco@gmail.com>2022-06-02 13:05:12 +0200
committerMacroFake <falke.marco@gmail.com>2022-06-02 13:05:29 +0200
commit39ddd522c37f760c8054d2fa58e026c69a50ce8b (patch)
tree2301ee88e0511a837b6229903ec4482e76b36586 /src/Makefile.am
parent1c7ef0abd11f35a27cc860ceb7e075b78f53cecf (diff)
parentfa72e0ba15c6382e9068be221ab4872bef000cbc (diff)
downloadbitcoin-39ddd522c37f760c8054d2fa58e026c69a50ce8b.tar.xz
Merge bitcoin/bitcoin#24531: Use designated initializers
fa72e0ba15c6382e9068be221ab4872bef000cbc Use designated initializers (MarcoFalke) Pull request description: Designated initializers are supported since gcc 4.7 (Our minimum required is 8) and clang 3 (Our minimum required is 7). They work out of the box with C++17, and only msvc requires the C++20 flag to be set. I don't expect any of our msvc users will run into issues due to this. See also https://bitcoin.jonasschnelli.ch/ircmeetings/logs/bitcoin-core-dev/2022/bitcoin-core-dev.2022-03-10-19.00.log.html#l-114 ACKs for top commit: kristapsk: ACK fa72e0ba15c6382e9068be221ab4872bef000cbc hebasto: ACK fa72e0ba15c6382e9068be221ab4872bef000cbc Tree-SHA512: a198e9addd9af69262a7e79ae4377b55697c8dfe768b8b3d444526544b1d1f85df46f0ae81b7541bf2f73e5868fb944b159e5bf234303c7b8b9d778afb0b2840
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eac8156956..d80bd79d53 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -254,6 +254,7 @@ BITCOIN_CORE_H = \
util/bip32.h \
util/bytevectorhash.h \
util/check.h \
+ util/designator.h \
util/epochguard.h \
util/error.h \
util/fastrange.h \