aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2022-03-10 22:13:58 -0500
committerTheCharlatan <seb.kung@gmail.com>2023-03-15 16:43:31 +0100
commit382b692a503355df7347efd9c128aff465b5583e (patch)
tree8437d33c9cd659a3663df4e2dea064284e326fe2 /src/Makefile.am
parentedabbc78a3bc272b2b802e1dbab73d6ed8e31e96 (diff)
downloadbitcoin-382b692a503355df7347efd9c128aff465b5583e.tar.xz
Split non/kernel chainparams
Moves chainparams code not using the ArgsManager to the kernel. Subsequently use the kernel chainparams header now where possible in order to further decouple chainparams call sites from gArgs.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a0c1670287..00db655e02 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -175,6 +175,7 @@ BITCOIN_CORE_H = \
interfaces/node.h \
interfaces/wallet.h \
kernel/chain.h \
+ kernel/chainparams.h \
kernel/chainstatemanager_opts.h \
kernel/checks.h \
kernel/coinstats.h \
@@ -651,6 +652,7 @@ libbitcoin_common_a_SOURCES = \
deploymentinfo.cpp \
external_signer.cpp \
init/common.cpp \
+ kernel/chainparams.cpp \
key.cpp \
key_io.cpp \
merkleblock.cpp \
@@ -907,6 +909,7 @@ libbitcoinkernel_la_SOURCES = \
hash.cpp \
kernel/chain.cpp \
kernel/checks.cpp \
+ kernel/chainparams.cpp \
kernel/coinstats.cpp \
kernel/context.cpp \
kernel/cs_main.cpp \