aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2023-05-04 12:07:26 +0100
committerfanquake <fanquake@gmail.com>2023-06-16 10:38:19 +0100
commit32e2ffc39374f61bb2435da507f285459985df9e (patch)
tree44103a701bd14b0c77163db5d557215d40842210 /src/Makefile.am
parentb3db18a0126bc4181d2a0880c27f45d203d06179 (diff)
downloadbitcoin-32e2ffc39374f61bb2435da507f285459985df9e.tar.xz
Remove the syscall sandbox
After initially being merged in #20487, it's no-longer clear that an internal syscall sandboxing mechanism is something that Bitcoin Core should have/maintain, especially when compared to better maintained/supported alterantives, i.e firejail. Note that given where it's used, the sandbox also gets dragged into the kernel. There is some related discussion in #24771. This should not require any sort of deprecation, as this was only ever an opt-in, experimental feature. Closes #24771.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b4ff556eb6..85c3eaf08d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -313,7 +313,6 @@ BITCOIN_CORE_H = \
util/sock.h \
util/spanparsing.h \
util/string.h \
- util/syscall_sandbox.h \
util/syserror.h \
util/thread.h \
util/threadinterrupt.h \
@@ -741,7 +740,6 @@ libbitcoin_util_a_SOURCES = \
util/spanparsing.cpp \
util/strencodings.cpp \
util/string.cpp \
- util/syscall_sandbox.cpp \
util/time.cpp \
util/tokenpipe.cpp \
$(BITCOIN_CORE_H)
@@ -976,7 +974,6 @@ libbitcoinkernel_la_SOURCES = \
util/serfloat.cpp \
util/strencodings.cpp \
util/string.cpp \
- util/syscall_sandbox.cpp \
util/syserror.cpp \
util/thread.cpp \
util/threadnames.cpp \