aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-07-05 12:44:12 +0200
committerMarcoFalke <*~=`'#}+{/-|&$^_@721217.xyz>2023-07-13 11:51:07 +0200
commit000019e158ef01f2bedc3fc1589f95e106e817ea (patch)
tree073bdd3a2cb43bc6f628d632282b7e6e15fc9d5d /src/Makefile.am
parentfa7724bc9d94c08d8facccd0a067d6a3b27fbbc6 (diff)
downloadbitcoin-000019e158ef01f2bedc3fc1589f95e106e817ea.tar.xz
Add AutoFile::detail_fread member function
New code can call the method without having first to retrieve the raw FILE* pointer via Get(). Also, move implementation to the cpp file. Can be reviewed with: --color-moved=dimmed-zebra --color-moved-ws=ignore-all-space
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4e9c161c57..cdf2df4f2e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -715,6 +715,7 @@ libbitcoin_util_a_SOURCES = \
logging.cpp \
random.cpp \
randomenv.cpp \
+ streams.cpp \
support/cleanse.cpp \
sync.cpp \
util/asmap.cpp \
@@ -958,6 +959,7 @@ libbitcoinkernel_la_SOURCES = \
script/standard.cpp \
shutdown.cpp \
signet.cpp \
+ streams.cpp \
support/cleanse.cpp \
support/lockedpool.cpp \
sync.cpp \